Ubuntu Linux Development Environment: Trellis

Trellis relies on a few other software tools. Install these tools:

  • VirtualBox >= 4.3.10
  • Vagrant >= 1.8.5
  • Ansible >= 2.4

VirtualBox

Install VirtualBox from the standard Ubuntu software repositories:

$ sudo apt-get install virtualbox

Vagrant

Install Vagrant from the standard Ubuntu software repositories:

$ sudo apt-get install vagrant

Ansible

If you don't already have pip (Python package manager) installed, install it:

$ sudo apt-get install python-pip

Install Ansible with pip:

$ pip install ansible

To install a specific Ansible version:

$ pip install ansible==2.4.0.0

Join over 5,800 subscribers on our newsletter to get the latest Roots updates, along with occasional tips on building better WordPress sites.

Looking for WordPress plugin recommendations, the newest modern WordPress projects, and general web development tips and articles?

“Easily the best WordPress email I get.” Colin OBrien

Follow us on Twitter @rootswp

Ready to checkout?